Preparing Power LPARs for import into Skytap
Skytap provides tools to help you export your on-premises Power A CPU architecture that supports IBM i, AIX, and Linux (on Power) in Skytap. LPARs to disk images that you can then import into Skytap environments. The toolset consists of a pair of scripts that you copy to an empty hard disk on the same LPAR that you want to import into Skytap. The scripts make disk images of the hard disks that you specify and then create an OVF file that contains an index of all the hard disk images. Then you use the Skytap VM Import tool to create a VM from the OVF file and disk images.
-
On the LPAR you intend to export, make sure that
/etc/security/limits
contains the following settings:default: fsize = -1 root: data = -1 fsize = -1
- Prepare rootvg for export using
alt_disk_copy
. For details, see the alt_disk_copy Command reference help. -
Download the Skytap aix-export tool from GitHub: https://github.com/skytap/aix-export.
The Skytap aix-export tool consists of two scripts:
export_lpar.ksh
andmake_ovf.ksh
. - On the LPAR you want to import to Skytap, copy the scripts to the target disk where the disk images will be saved. Make sure the target disk has enough space to accommodate all of the hard disks that you plan to export.
-
Create the export package with the following command:
/export_lpar.ksh hdisk1 [hdisk2] … [hdiskn]
If there are multiple hard disks, be sure to specify the bootable hard disk first. In the example above,
hdisk1
is the bootable disk.Don’t include the hard disk where the export scripts are running. For example, if you copied the scripts to
hdisk4
, don’t includehdisk4
in theexport_lpar.ksh
command line.- Disk image (.img) files are created for all of the hard disks that you specified in the command, in the same directory where you ran
export_lpar.ksh
. - When
export_lpar.ksh
completes, it automatically runsmake_ovf.ksh
to create<hostname>.ovf
, which contains an index of the .img files that were exported byexport_lpar.ksh
. -
Recommended: To reduce file transfer times when you import the LPAR into Skytap, you can combine
<hostname>.ovf
and its indexed .img files into a single, compressed .ova file with the following command:tar -cvf - <hostname>.ovf <hostname>-disk1.img [<hostname>-disk2.img] … [<hostname>-diskn.img] | gzip > <hostname>.ova
The combined, uncompressed file size of the LPAR hard disk image files must be less than 4 TB. If the collection of files to be imported exceeds 4 TB, contact Skytap Support at support@skytap.com to enable import of larger LPAR file sets.
- Disk image (.img) files are created for all of the hard disks that you specified in the command, in the same directory where you ran